https://kedro.org/ logo
#questions
Title
# questions
s

Susana

04/01/2024, 10:50 AM
Hi everyone! I am developing my thesis on which I have to test an algorithm. That algorithm is in a Kedro pipeline on GitHub, click here. I have attempted to follow Kedro documentation to run projects in Jupyter Notebooks and saw YouTube videos, however, I haven’t really understood yet Kedro and keep getting errors when I try to run experiments. I feel like a noob: all I want to do is run the algorithm in datasets I have, but I don’t even understand the error I get like ‘missing 5 required positional arguments’ - or I do understand them, but I don’t know / haven’t been able to define those arguments or run it properly. Anyone here could please help me with this? I would be forever grateful since my thesis depends on running this algorithm 😞
You don't have to create context yourself, it is just one command I suggest to read through this page

https://youtu.be/3q2RNWLibyY?si=DszejhohoGM5xmv0

s

Susana

04/01/2024, 12:08 PM
Hi! Thank you for your suggestion I had already tried to follow that documentation and the youtube videos, and it didn't work. I am still not able to run the algorithm. It gives me errors or things that I don't understand, and that is why I would really appreciate if anyone could please meet with me or something to try to see what is happening! Thank you so much
i

Iñigo Hidalgo

04/01/2024, 12:41 PM
Hi Teresa. Looking at the code in that folder you sent it doesn't look like there are any pipelines defined in the code so there is nothing to run. There is no code, data or config in the folder you shared.
s

Susana

04/01/2024, 1:33 PM
Hi Iñigo! I think there is. Inside the src/pub folder there's the pipeline
i

Iñigo Hidalgo

04/01/2024, 1:35 PM
if you open that folder there is no actual pipeline code. all the files in there are automatically created by kedro, there should be code in src/pub/pipelines/ but there is nothing there.
the 2 or 3 folders i looked at in
published_work
don't have any code in them
s

Susana

04/01/2024, 1:36 PM
Okay, but inside src/pub there's a file named 'pipeline_registry.py'
i

Iñigo Hidalgo

04/01/2024, 1:37 PM
i'm not going to be able to help you further than this, you should check with the repo owner what you're expected to do because, as the folders are right now, there is no executable code in that folder
n

Nok Lam Chan

04/01/2024, 9:30 PM
Agree with @Iñigo Hidalgo , unfortunately there is not much we can help here. The best chance you have is to contact the repo owner, I don’t see there are any code at all.
👍 1
j

Juan Luis

04/02/2024, 5:55 AM
hi @Susana, to clarify what my colleagues said, I checked out all the files on that project and they are all Kedro boilerplate, there are no pipelines defined in the project unfortunately. I see that research team frequently uses Kedro in their pipelines. just sent them an email and cc'ed you 🤞🏼
K 2
i

Iñigo Hidalgo

04/02/2024, 10:14 AM
Thanks for the follow-up and clarification Juanlu. Good luck with your thesis @Susana 🙂