https://kedro.org/ logo
#questions
Title
# questions
b

Beyza Hizli

03/18/2024, 3:08 PM
Hey I have a question! I'm new here, so please let me know if this message does not belong here: My current python projects are using
python = "3.9.*"
. When I try to upgrade kedro-viz to 8.0.1, I get the following error: The current project's Python requirement (==3.9.*) is not compatible with some of the required packages Python requirement: - kedro-viz requires Python >=3.9, so it will not be satisfied for Python >=3.9.dev0 But shouldn't it be satisfied? (I know that if I change the python version to
"^3.9"
it works, but ideally I'd like to prevent that)
K 1
d

Deepyaman Datta

03/18/2024, 3:11 PM
(I know that if I change the python version to
"^3.9"
it works, but ideally I'd like to prevent that)
Why do you want to avoid that? This seems like a pretty pedantic thing, where your version specifier for Python is including pre-release Python 3.9 versions. Are you perhaps OK with
"~3.9"
, if you want to avoid 3.10+?
I'm assuming you're using Poetry; can be helpful to specify. 🙂
b

Beyza Hizli

03/18/2024, 3:17 PM
Thanks for your quick reply! I'm indeed using Poetry. I want to avoid 3.10 but also preferred it for consistency (all our projects are using =3.9.*).
~3.9
should work to avoid 3.10 indeed, so I might just do that. But it still makes me wonder why
=3.9.*
does not work.
d

Deepyaman Datta

03/18/2024, 3:18 PM
Because
3.9.*
technically matches
3.9.dev0
, which is not matched by
>=3.9
b

Beyza Hizli

03/18/2024, 3:19 PM
Oh I see, I didn't know that. Thanks 🙂
👍 1
👍🏼 1
d

Deepyaman Datta

03/18/2024, 3:19 PM
This is an edge case you probably don't care about, since you don't have users using pre-release versions of 3.9. Kedro-Viz probably doesn't want to enable pre-release 3.9 versions in it's support matrix, either.
2 Views