https://kedro.org/ logo
#questions
Title
# questions
h

Higor Carmanini

02/19/2024, 10:23 PM
Is there a way of installing only the data catalog part of Kedro?
j

Juan Luis

02/19/2024, 10:29 PM
not at present, but it has been requested in the past. how would this help you?
or rather, what would you remove from Kedro? 😄 a installable
DataCatalog
would be nice, but without
OmegaConfigLoader
it wouldn’t support dataset factories, custom resolvers etc.
h

Higor Carmanini

02/19/2024, 10:38 PM
For our use case, only the DataCatalog part is relevant - nothing about the nodes, pipelines or orchestration. So I'm thinking this might help us avoid additional dependencies. For some reason, some clients also don't like and/or accept Kedro as well 🤔
j

Juan Luis

02/20/2024, 7:15 AM
so would you say it's nothing in specific, just keeping things lean?
👌 1
(about clients not accepting Kedro, if you have extra insight, I'd be happy to hear 👂🏼)
n

Nok Lam Chan

02/20/2024, 12:49 PM
For our use case, only the DataCatalog part is relevant - nothing about the nodes, pipelines or orchestration. So I'm thinking this might help us avoid additional dependencies.
For some reason, some clients also don't like and/or accept Kedro as well 🤔
Would having
kedro[catalog]
helps in this case? This is the core dependency of kedro and there is not much heavy dependencies. Maybe
dynaconf
,
omegaconf
(if you don't need config loader), and
toposort
are not required with data catalog.
Copy code
dependencies = [
    "attrs>=21.3",
    "build>=0.7.0",
    "cachetools>=4.1",
    "click>=4.0",
    "cookiecutter>=2.1.1,<3.0",
    "dynaconf>=3.1.2,<4.0",
    "fsspec>=2021.4",
    "gitpython>=3.0",
    "importlib-metadata>=3.6,<8.0; python_version >= '3.8'",
    "importlib_resources>=1.3,<7.0",  # The `files()` API was introduced in `importlib_resources` 1.3 and Python 3.9.
    "jmespath>=0.9.5",
    "more_itertools>=8.14.0",
    "omegaconf>=2.1.1",
    "parse>=1.19.0",
    "pluggy>=1.0, <1.4.0",
    "pre-commit-hooks",
    "PyYAML>=4.2,<7.0",
    "rich>=12.0,<14.0",
    "rope>=0.21,<2.0",  # subject to LGPLv3 license
    "toml>=0.10.0",
    "toposort>=1.5",  # Needs to be at least 1.5 to be able to raise CircularDependencyError
]
8 Views