Hi, I am facing the following issue: I pyproject....
# questions
a
Hi, I am facing the following issue: I pyproject.toml file I have the following requirement:
apache-airflow = {version = "2.3.0", extras = ["kubernetes"]}
and i am trying to install kedro and I am getting the following error:
Copy code
Because no versions of kedro match >0.19.6,<0.20.0
 and kedro (0.19.6) depends on attrs (>=21.3), kedro (>=0.19.6,<0.20.0) requires attrs (>=21.3).
And because apache-airflow (2.3.0) depends on attrs (>=20.0,<21.0), kedro (>=0.19.6,<0.20.0) is incompatible with apache-airflow (2.3.0).
So, because airflow-poc depends on both kedro (^0.19.6) and apache-airflow (2.3.0), version solving failed.
has anybody solved that?
n
whatis the apachepoc? The latest kedro is 0.19.6, I believe that's likely your own package have an incorrect pin
a
thank you will try now, that is what automatically airflow installed but you are correct. All worked, thank you
🙌 1