hello I have this error when I run the kedro new ...
# questions
hello I have this error when I run the kedro new can anyone help me plz : [05/13/24 153043] ERROR Stopping generation because post_gen_project hook script didn't exit successfully hooks.py:164 Traceback (most recent call last): File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\kedro\framework\cli\starters.py", line 911, in _create_project result_path = cookiecutter(template=template_path, **cookiecutter_args) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\cookiecutter\main.py", line 182, in cookiecutter result = generate_files( ^^^^^^^^^^^^^^^ File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\cookiecutter\generate.py", line 419, in generate_files run_hook_from_repo_dir( File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\cookiecutter\hooks.py", line 157, in run_hook_from_repo_dir run_hook(hook_name, project_dir, context) File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\cookiecutter\hooks.py", line 140, in run_hook run_script_with_context(script, project_dir, context) File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\cookiecutter\hooks.py", line 123, in run_script_with_context run_script(temp.name, cwd) File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\cookiecutter\hooks.py", line 94, in run_script raise FailedHookException( cookiecutter.exceptions.FailedHookException: Hook script failed (exit status: 1) The above exception was the direct cause of the following exception: Traceback (most recent call last): File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\click\core.py", line 1078, in main rv = self.invoke(ctx) ^^^^^^^^^^^^^^^^ File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\click\core.py", line 1688, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\click\core.py", line 1434, in invoke return ctx.invoke(self.callback, **ctx.params) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\click\core.py", line 783, in invoke return __callback(*args, **kwargs) ^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\kedro\framework\cli\starters.py", line 360, in new _create_project(project_template, cookiecutter_args, telemetry_consent) File "C:\Users\Cherqaoui\anaconda3\envs\kedro_update\Lib\site-packages\kedro\framework\cli\starters.py", line 917, in _create_project raise KedroCliError( kedro.framework.cli.utils.KedroCliError: Failed to generate project when running cookiecutter.
Hi @Rachid Cherqaoui can you tell me what version of kedro you are using?
And what versions of click and cookiecutter are installed?
I have cookiecutter = 2.5.0 & kedro = 0.19.14 and I used 0.19.15 too but still the same error
What version of python are you using and can you describe what steps you took.
I have 3.11
n I tried to use other version of python but still the same error
Can you describe what you did exactly so I can try recreate it.
i would just begin a new project from scrutch with kedro new so I install a new env and kedro 0.19.4 and other dependecies, n when i run kedro new, I have this error
Hey Rachid, I'm not able to recreate it, it might be worth clearing the cookiecutter cache.
cd ~
ls -a | grep .cookiecutters
rm -rf .cookiecutters
Then try
kedro new
❤️ 1