Hello! I ran into an issue when trying to do the f...
# questions
Hello! I ran into an issue when trying to do the following on a Databricks' Workflow run executing code in a DevOps repository:
with KedroSession.create(
) as session:
It seems that the default value for the class `KedroSession`parameter
while the default value for the
method for the same parameter is set to
. This is easy to fix as it is just a matter of explicitly passing the parameter, but it seems contradictory. Is there a reason for keeping these two defaults different? Thanks!
👀 1
Hey Juan, is there anything specific you are trying to do where this difference in the defaults is causing an issue?
Might not be relevant, but when I'm running kedro on databricks I load the session using:
Copy code
%load_ext kedro.ipython
%reload_kedro project_root --env=s3_dev
This creates the global session variable in the notebook and then I use session.run etc. Could be a work around for your issue if it's to do with your method of defining the session?
Can you elaborate what is the problem here or do you just need some clarification? The standard way of creating KedroSession is through the factory method "create". I do not know what the init method have a different default. I suspect it's mostly legacy code. In fact the session save method do less than it used to be. It's likely not important but something that we should revisit when we start the redesign work of KedroSession
https://github.com/kedro-org/kedro/milestone/46 There is a milestone about it but we haven't started any work yet.