https://kedro.org/ logo
#questions
Title
# questions
i

Iñigo Hidalgo

02/02/2024, 10:30 AM
I will go searching the dependencies myself so don't bother looking it up, just asking in case anybody knows the answer offhand: I am listing a dependency range for kedro as >=0.17.1,<0.19. When installing the library on a 3.8 venv it resolves kedro to 0.18.14 whereas if I install it on 3.10 it's resolving to 0.18.12?? I assume it's from some transitive dependency which for some reason became incompatible from 0.18.13, but it's counterintuitive that it's the higher python version which is incompatible with 0.18.13 EDIT: cannot reproduce this behavior reliably, gonna chalk it up to weird pip stuff
Strange, if I set a constraints.txt to kedro==0.18.14 it resolves correctly
j

Juan Luis

02/02/2024, 1:15 PM
there's a new version of pip that was causing some trouble, @Nok Lam Chan do you remember what it was? I remember you were involved in the conversations
n

Nok Lam Chan

02/02/2024, 1:18 PM
# pip==23.2 breaks pip-tools<7.0, and pip-tools>=7.0 does not support Python 3.7
# pip==23.3 breaks dependency resolution
"pip>=21.2,<23.2",
from our e2e tests setup