https://kedro.org/ logo
#questions
Title
# questions
t

Trevor

11/14/2023, 5:29 PM
Solved. Welp. That was dumb. It was a naming issue so I was returning the plot module rather than the plot pipeline. Disregard I think this might be a versioning question I created a kedro project with v0.18.8 some time ago, using
kedro new
. Everything has worked fine until now (I ran it just a moment ago and everything looked ok). Now I'm back working on that project (now using kedro v0.18.13) and wanted to add a new pipeline so I created a new pipeline named "plot" with
kedro pipeline create plot
. Just to plot some results. I edited all the source as needed in
nodes.py
and
pipeline.py
. I added
from [project name].pipelines import plot
and
plot_pipeline = plot.create_pipeline()
to
pipeline_registry.py
and edited the return dictionary of
register_pipelines()
to include
"plot": plot_pipeline
.
But when I go to run the pipeline with
kedro run
, I get an unsupported operand type between Pipeline and module when trying to run the default pipeline. Did something change between 0.18.8 and 0.18.13 that changed the way you create a pipeline?
👌 1
👌🏼 1
The commented out print of
find_pipelines()
prints out the correct pipelines, including the "plot" pipeline.
6 Views