Hi Team, I am getting an error in my CI today, wh...
# questions
Hi Team, I am getting an error in my CI today, when trying to install kedro-viz
Copy code
ERROR: Could not find a version that satisfies the requirement kedro-viz<4.0,>=3.3.0 (from versions: 4.5.0, 4.6.0, 4.7.0, 4.7.1, 4.7.2, 5.0.0, 5.0.1, 5.1.1, 5.2.0, 5.2.1, 5.3.0, 6.0.0, 6.0.1, 6.1.0, 6.1.1, 6.2.0, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.3.4, 6.4.0, 6.5.0, 6.6.0, 6.6.1)
ERROR: No matching distribution found for kedro-viz<4.0,>=3.3.0
Till yesterday it ran without any issues, python version 3.9 🙂
Can you not upgrade your Kedro Viz? The latest version is v6.6.1
We have a dependency clash with some other packages, previously. But let me try this 😞
are you using pip-compile?
it can help you resolve this sort of problem
okie, thanks
On the other hand you may want to check your repository and see if there are any dependencies change?
@tom kurian notice that kedro-viz<4.0 did not support Python 3.9. you can check this if you open the
file from the wheel https://pypi.org/project/kedro-viz/3.17.1/#files
Copy code
Requires-Python: >=3.6, <3.9
K 1
the only reason why you might have been able to install those Kedro Viz versions in the past for Python 3.9 is that maybe you were using an older
if you want to use Kedro Viz on Python 3.9, at least you'll need to use 4.5.0
👍 1