Hi, I tried migrating to the `OmegaConfigLoader` f...
# questions
Hi, I tried migrating to the
following the kedro docs. I have previously had a hacky parametrized by env vars TemplatedConfigLoader setup (but it worked), and now after successfully interpolating most of the config, I get a
Copy code
omegaconf.errors.UnsupportedInterpolationType: Unsupported interpolation type oc.env
    full_key: general.df_with_tags.filepath
error. By placing some strategic breakpoint, I have deduced that the
field in BaseContainer seems to be missing the
resolver later, but initially it is able to look it up as its in the list. Dont know how to proceed, any help is appreciated. Thank you in advance ๐Ÿ™
โœ… 1
What configuration file are you using
in? By default itโ€™s only supported for credentials, and if you want to us it in other config files youโ€™ll need to enable it explicitly: https://docs.kedro.org/en/stable/configuration/advanced_configuration.html#how-to-use-resolvers-in-the-omegaconfigloader
๐Ÿ‘ 1
๐Ÿ‘๐Ÿผ 1
Yes, thats it! I assumed it was enabled by default! Thanks!
Thanks for a timely and spot on response! ๐Ÿ™‚ ๐Ÿ”ฅ
๐Ÿ˜„ 1