I ran `kedro viz` on the `spaceflights` starter ki...
# questions
I ran
kedro viz
on the
starter kit and it does open a tab with local address and port 4141, but the page is completely blank. It did say
"Kedro Viz Backend Server started successfully..."
So not sure why it's still blank.
kedro run
can be executed from end to end as well. Just to be clear, this happens on a remote shared server. I've made a fresh conda environment and reinstalling everything from scratch, but it doesn't seem to solve the blank issue with kedro viz.
Hi Afiq, do you have any other process already running on port 4141 when you tried running kedro viz ?
@Ravi Kumar Pilla, not really, I mean previously there was, I think because since it's a shared server, my fellow colleague runs
kedro viz
and it must be using the same port. But I've made sure that the port is available and hence why I think the command prompt did output
"Kedro Viz Backend Server started successfully..."
Otherwise I don't see any other error message by kedro viz. Maybe I can try to check the web developer tools in the browser to see the source from which it should show something instead of a blank page?
👀 1
Hello @Afiq Johari. It happens sometimes to me. A solution I found is trying refreshing a few times. If not working I kill all my terminals and start again. Good luck
@Hugo Rebeix Thanks for the sharing! My colleague figures out that ours is mainly due to some security issues, had to patch the codebase to work through this issue, it works now.
👍 1